PyTorch 1.8.1-fosscuda-2020b

There is a newer install of PyTorch

Tensors and Dynamic neural networks in Python with strong GPU acceleration. PyTorch is a deep learning framework that puts Python first.

Accessing PyTorch 1.8.1-fosscuda-2020b

To load the module for PyTorch 1.8.1-fosscuda-2020b please use this command on Baskerville:

module load bask-apps/test
module load PyTorch/1.8.1-fosscuda-2020b

Bask Apps Env

test

More Information

For more information visit the PyTorch website.

Dependencies

This version of PyTorch has a direct dependency on: cuDNN/8.0.4.30-CUDA-11.1.1 FFmpeg/4.3.1-GCCcore-10.2.0 fosscuda/2020b GMP/6.2.0-GCCcore-10.2.0 magma/2.5.4-fosscuda-2020b MPFR/4.1.0-GCCcore-10.2.0 NCCL/2.8.3-GCCcore-10.2.0-CUDA-11.1.1 Ninja/1.10.1-GCCcore-10.2.0 numactl/2.0.13-GCCcore-10.2.0 Pillow/8.0.1-GCCcore-10.2.0 protobuf/3.14.0-GCCcore-10.2.0 protobuf-python/3.14.0-GCCcore-10.2.0 pybind11/2.6.0-GCCcore-10.2.0 Python/3.8.6-GCCcore-10.2.0 PyYAML/5.3.1-GCCcore-10.2.0 SciPy-bundle/2020.11-fosscuda-2020b typing-extensions/3.7.4.3-GCCcore-10.2.0

Required By

This version of PyTorch is a direct dependent of: Horovod/0.22.1-fosscuda-2020b-PyTorch-1.8.1 PyTorch3D/0.5.0-fosscuda-2020b-PyTorch-1.8.1 PyTorch3D/0.4.0-fosscuda-2020b-PyTorch-1.8.1 tensorboardX/2.4-fosscuda-2020b-PyTorch-1.8.1 torchvision/0.9.1-fosscuda-2020b-PyTorch-1.8.1

Other Versions

These versions of PyTorch are available on Baskerville. These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 10th July 2021